• bejegyzés
    19
  • hozzászólás
    3.396
  • megtekintés
    18.350

Dupla router beállítás, Home, Barbone, szerver, Otthoni hálózatokról minden

Dupla router beállítás

Lakossági előfizetőként most már csak Home Gatewayt kapunk, ez a állat fajta egy három funkciós eszköz modem router és switch így egyben. A nagy probléma csak az hogy nyertünk egy dupla natolást. Francnak nem hiányzik, kívülről befele haladva T-s HGW oszt nekünk egy 192.168.X.X címet e mögött, a mi routerünk is oszt egy hasonló címet. Ez után a mi gépünk meg nagyon nem lát kifele semmit. Ami gond ha üzemeltetünk bármilyen szolgáltatást aminek kell egy port nyitás.   Torrent, NAS, VPN, FTP, online játékok stb a lista hosszú rengeteg ilyen van. 

Kábelnet előfizető vagyok

  • Ha nincs iptv előfizetésed és mellé Cisco EPC3925 vagy Sagemcom F@st 3686AC HGW nálad. Akkor a 1412 felhívása után kérhetsz bridge módot. Ez a legszebb legtisztább megoldás, ilyenkor eszköz 1-es sorszámú csatlakozójára elég egy utp kábelt kötni, másik felét saját routerünk wan portjára és meg is vagyunk.
     
  • Van iptv előfizetésem: Saját routerben akkor ki kell kapcsolni a dhcp servert és az egyik lan lábára kötni az utp kábelt. Ilyenkor fontos módosítani azt a címet amin eléred. Tehát ha a saját routert a 192.168.0.1 címen éred el és  a T-s HGW-nek is ez a címe, akkor a saját routered nem fogod elérni. Ezért célszerű módosítani egy másik címre.  Illetve a T-s eszközben célszerű egy statikus címgofalást csinálni és dmz be rakni azt a címet amit ki osztott, a saját routerünknek.

Xdsl előfizető vagyok

  • Speedport W724V esetén van PPPoE Passthrough pipa be. Ezután saját routerrel hozhatjuk létre a PPPoE kapcsolatot. 

Optinet előfizető vagyok

  • Ha tudja a HGW PPPoE Passthrough funkiciót akkor ugyan az a teendőnk mint az Xdsl előfizetőknek.

Wifi sebesség és egyéb tippek

Vezeték nélküli hálózatoknál gyakori tünetek. Sebesség csökkenés, magas ping megbízhatatlan szakadozó kapcsolat. Gyenge jelszint ház másik felében alig vagy egyáltalán nincs kapcsolat. Számítógépre inSSIDer, androidos eszközökre Wifi Analyzer  programokat tudom javasolni.  Környezetünkben lévő vezeték nélküli hálózatok felderítésére. Nézzünk is meg egy képet ehhez kezdésnek. 

inSSIDerGraph1.png

Jól látszik hogy azonos csatornán van, az én wifi hálózatom HG520b és egy másik. Amennyiben lehetőség van rá próbáljuk szabad csatornára átenni. Esetünkben 9-13 között bárhol. Ez megoldhatja a wifi szakadásokat sávszél gondot.  

Mindezek mellet számos hgw/router bele hallgat a rádiós közegbe, hogy melyik csatorna lenne a legjobb.  Sajnos ez is okozhat problémákat. Nagyobb sebességet tudunk elérni ha 40 mhz width re állítjuk a csatorna szélességet. 

Iptv  alternatív bekötése 

Talán hat éve már hogy T Iptv szolgáltatás elindulása mellet tette le a voksot, amivel xDsl és Optinet hálózaton is nyújthat tv szolgáltatást.  Ez alapjáraton nem lenne akkora gond, de  valljuk be oké mégis gond több okból. Nézzük a T álláspontját adok egy HGW-t amiből közvetlen útvonalat húzok a set top box-hoz utp kábellel és kész. Ez jó mert egyszerű és egy  kisebb kvalitású szerelő is meg tudja csinálni, viszonylag olcsón és kvázi hiba mentes megoldás. De valljuk be ez nem mindenkinek jó, vannak pöpet nagyobb igényű felhasználók akik teszem azt integrálni szeretnék egy meglévő hálózatba az iptv-t.  Ehhez  elhoztam most pár szituációt, ami a közösségi média felületein többször szembe jött velem.

Egy utp kábel van a szobában, amire már rá van kötve a birodalmi lépegető. Nem akarok több kábelt nem is fér el stb

100Mbps-on működik a  a következő megoldás ami elég egyszerű. Szét bontjuk a 8 eret 1,2,3,6 vagyis a sárga fehér, sárga, zöld fehér, zöld ereket kell jó helyre kötni. Majd a fennmaradó ereket 4,5,7,8 ugyan ezekre a helyekre kell bekötni csak egy másik csatlakozón. De ha nem akarunk ezzel szórakozni vegyünk két darab y utp osztót két toldót és kb 2000 Ft-ból meg is úsztuk.

UTP_kozosites_PC.png                                                                                                                                        Forrás IT café

Nem akarok kábeleket mert fúrni faragni kéne vezeték nélküli megoldások híve vagyok. 

HGW és a Iptv beltéri egység közt egy vezeték nélküli hálózatot kell létre hozni. Ennek a hátránya hogy átviteli minőség messze alul maradhat a többi megoldáshoz képest, helyszíni felmérésé szükséges hozzá. Előnyei közé sorolható minimális szerelési munka, később könnyen áthelyezhetőek a végpontok.

 

Vasbeton házban élek és különben is veszélyes az egészségemre és nem akarok kábeleket. 

Semmi gond powerline azaz plc adapter lesz a számodra egy jó megoldás.  Történet két végére kel egy egy adapter ami a meglévő, elektromos hálózaton továbbítja az internetet. Viszont olyan formában hogy a szomszéd erre nem tud csatlakozni ami jó.

PLC-550+-Duo-scenario_devices-xl-2954.jpg

 

Van már egy meglévő csillagpontos koax hálózat a lakásomban. Nem akarok több kábelt, fúrást faragást. 

Eoc technológia használata javasolt.  Meglévő koax hálózaton kerül továbbításra az iptv szolgáltatás, ami minimális többlet költséggel jár. Viszont nem fogyaszt áramot ami valljuk be jó dolog.  Ennek a megoldásnak hátrányaihoz sorolható talán az hogy, fix végpontunk lesz és nem lehet olyan könnyen A-bol B-be vinni. nagy.jpg                                                                                                                                  Forrás: www.telekom.hu

Alternatív vezetékezési lehetőségek iránti igényt, szerződés kötéskor de legkésőbb létesítéskor jelezni kell. De jobb ha szerződés kötéskor kerül jelzésre, nem biztos hogy lesz minden szakértő kollégánál a kocsiban eszköz.  

Eszközök

Cable Vision EOC-IN:

  • egy összegben: 4 440 Ft
  • Telekom TV előfizetőknek 3 havi kamatmentes részletre (THM 0%): 1 480 Ft

Technicolor TG234 WiFi Bridge:

  • egy összegben: 16 900 Ft
  • Telekom TV előfizetőknek 10 havi kamatmentes részletre (THM 0%): 1 690 Ft

D-Link DHP-P509:

  • egy összegben: 11 900 Ft
  • Telekom TV előfizetőknek 10 havi kamatmentes részletre (THM 0%): 1 190 Ft

 

Mit tehetek áramszünet esetén ?

Xdsl előfizető vagyok

Szerencsés vagy elég egy szünet mentes tápegységet vásárolnod, és pillanatnyi vagy huzamosabb áramszünet alatt is aktív internet kapcsolatod lesz.  Ennek az a egyszerű oka hogy DSLAM és közted nincs olyan hálózati elem ami külön áramot igényelne. Továbbá azért is hasznos mert így elkerülhetjük snr lock-ot, ez annyit jelent ha megszakad a kapcsolat előfordul hogy a DSLAM kisebb sebességre vissza tesz minket. 

Optinet előfizető vagyok

Szintén szerencsés vagy, mivel az optikai hálózat egy nagyon egyszerű passzív hálózat. Így áramszünet esetén neked is segít egy szünet mentes tápegység.

Kábelnet előfizető vagyok

Nem vagy szerencsés előfizető :( , vehetsz szünetmentes tápot viszont esetek nagy többségében nem jelent megoldást ez neked. CMTS szünetmentes árameltátása megoldott eddig pipa. Viszont az Onu szünet mentes ellátása nem megoldott, ez nem csak a T-nél van így.  Ha ez nem kap áramot akkor utána következő hálózat se.  Akkor lehet megoldás ha CMTS  Onu páros rendben van és egy lokális áram szünet van ami előfizetőket érinti csak. Volt erre Amerikában próbálkozás sőt Cisco gyártott is akkumulátorral ellátott modemet. Viszont ezek DOCSIS és nem EuroDOCSIS szabványosak voltak. 




245 megjegyzés




Mert szoftver és vagy hardver hibás az új málna. Gigabites linkel 50 Mbit a letöltés 100-as linken 93 Mbit. 

Megjegyzés megosztása


Link kommenthez

Sziasztok.

Segitséget szeretnék kérni mert kezdem feladni.
Mikrotik korábban működő hálózata elé(másik szolgáltató eszköze bridge módban volt) költözés és így szolgáltató váltás miatt T szolgáltató Sagem eszköze került.
Sagem-en DMZ beallitva 192.168.0.2.
Mikrotik meg is kapja eth1-en a fenti címet.
Net van, de hiába raktam dmz-be, a mikrotik mögött lévő NAS-on futó ftp -t nem érem el kívülről.
Mit kell máshogy beállítani a tűzfal/nat résznél?
Korábban nem volt ilyen probléma, mert bridge-ben volt a szolgáltatói eszköz.
IPTV miatt itt nem kivitelezhető sajnos.

A kérés eljut a mikrotikig csak olyan mint ha visszafelé nem kommunikálna....
A firewall conf. -bol kitoroltem minden egyeb rule-t, jelenleg annak is orulnek ha ftp-n elernem a nas-t.

A conf a következő jelenelg:
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add action=accept chain=forward comment="default configuration" connection-state=established,related log-prefix=accfw
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=ether1-gateway
add action=accept chain=input comment="default configuration" protocol=icmp
add action=accept chain=input comment="default configuration" connection-state=established,related
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway log-prefix=eth1gwdropinput
add action=accept chain=forward dst-port=21 log=yes log-prefix=ftp protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
add action=dst-nat chain=dstnat comment="NAS ftp port forward" dst-port=21 in-interface=ether1-gateway log=yes log-prefix=log_NAT protocol=tcp to-addresses=10.1.1.3 to-ports=21

 

Előre is köszönöm, ha vki tud segíteni!

Megjegyzés megosztása


Link kommenthez

Ugy erted, hogy a sagemen is fw-oljam a 21-es portot a DMZ cimre(192.168.0.2)?

Ezt probaltam, de ugyanugy nem mukodik.

Megjegyzés megosztása


Link kommenthez

@Kjan

Nem tudom hogy a magán hálózatodvan melyik eszköz címe a 0.2,de úgy kéne, hogy a szolgáltatóit forwardingolod a saját útválasztóra, azt pedig a nasra. Javaslom keress másik portot a 21-es helyett. 

Megjegyzés megosztása


Link kommenthez

0.2-n van a Mikrotik.
Jelenleg ez a cím van DMZ-ben a sagem-en, és erre van fw-va az ftp.
Illetve a mikrotik mögött pedig 10.1.1.3 címen van az ftp, így a mikrotikon erre fw-olom az ftp portot.

probaltam egyedi porton is ugysem ment :(

Megjegyzés megosztása


Link kommenthez

@Kjan

19-21 óráig Teamvieweres távsegítséget tudok ebben nyújtani, ha érdekel, írj privátban.

Megjegyzés megosztása


Link kommenthez

Hello Mindenkinek!

Egy kis segítséget szeretnék kérni.

HG8245H router a T-től, 192.168.1.x-en, ő a DHCP server is.

HG8245 LAN lábán egy ASUS AC-86U, router módban, a WAN csatlkozóban a kábel.

ASUS WAN : DHCP a HGW8245-től, kap címet, a HG8245-ön DHCP rezerváció van a címen, tehát mindig ugyanazt kapja.

ASUS LAN : 192.168.2.x, szintén DHCP server.

Egy laptoppal csatlakozom az ASUShoz UTP-n, megy a net, minden szép. Innen minden 192.168.1.x-en lévő hostot elérek.

Ha átmegyek a HG8245H-re szintén minden szép, kivéve hogy nem tudom az ASUS-t innen elérni és semmit sem a 192.168.2.x-n.

Az lenne a kérdésem hogy miért ?

Előre is köszönöm

Sunny

 

Megjegyzés megosztása


Link kommenthez

@Sunseeker

Gyanítom azért, mert az Asus minden WAN portjáról érkező kérést elutasít vagy eldob. 

Megoldás: Szüntesd meg a felesleges alhálózatot, dupla natot. 

Megjegyzés megosztása


Link kommenthez

@Sunseeker

Nem tudom pontosan milyen kapcsoló van azon az Asuson. Ha van rajta dedikált AP mód akkor állítsd be azt, ha a dhcp szervert külön ki kell kapcsolni akkor azt is inaktiváld, de lehet, hogy ez az AP mód bekapcsolásával automatikusan végbe megy. Kövesd a készülék User Manuálját 

Szerkesztve ekkor: Szerkesztő: btz

Megjegyzés megosztása


Link kommenthez

Értem hova akarsz kilyukadni, tudom is hogy miért javaslod az AP módot,de :)

Ezt az ASUS routert azért vettem, hogy VPN szerverként funkionáljon. Az pedig csak akkor működik, ha router módban van és a WAN porton van az UTP kábel.

Ezért találtam ki azt, hogy csinálok egy alhálózatot, ahova bepakolom azokat a dolgokat amiket el szeretnék érni, ha felépül a VPN. Csak a LAN-t szeretném látni.

A VPN szerver csak akkor ír IP-t a lementhető konfigba, ha a WAN porton van az UTP kábel, ha a LAN portba dugom, akkor 0.0.0.0, vélelmezem, hogy csak a WAN porttal működik.

Nem vagyok hálózati guru, ezért ha van jobb megoldás arra, amit szeretnék, akkor szívesen meghallgatom.

Köszönöm

Sunny

Megjegyzés megosztása


Link kommenthez

OPENVPN-ről beszélünk, azt nem írtam, illetve azt sem hogy a 1194-es portot a HG8245H-n az ASUS WAN portjára gondoltam forwardolni.

Megjegyzés megosztása


Link kommenthez

@Sunseeker

Értem, ha a VPN funkcióját is használni szeretnéd az Asusnak akkor a WAN portját állítsd Pppoe tipusra és az legyen a fő átjáró. A szolgáltatói ONT-n ekkor töröld ki a pppoe adatokat, kapcsold ki a DHCP server funkciót, majd ha szeretnéd, hogy LAN kapcsolat is legyen a két eszköz között, akkor LAN LAN is kösd össze a őket egy külön kábellel  az IP tartományokat állítsd megegyezőre (Pl 192.168.1.X) . Hátránya hogy ez lefoglalja az adott LAN portokat. 

Ha nem szeretnéd ennyire megvariálni, ahogy az előzőekben leírtam, akkor ha van valami külön tűzfal beállítás az Asuson amivel elfogad minden WAN felől bejövő kérést, akkor azt is beállíthatod, de mivel nem ismerem az adott típust, így ez csak egy tippként mondom, nem biztos hogy van rá lehetőség. 

Megjegyzés megosztása


Link kommenthez

Az első opciót szeretném elkerülni, mert elégedett vagyok az oNT-vel, sokminden már be van rajta lőve (évek óta) és minden jól működik.

Az ASUS-nak szinte kizárólag az OPEN VPN server funkcióját használnám, illetve a rajta lévő 4 switch portot a VPN-en látni kivánt eszközöknek.

Ebben az esetben is csak az általad vázolt 2 opcióm van ?

 

Megjegyzés megosztása


Link kommenthez

@Sunseeker

Talán még Openwrt szoftverrel ha el lehetne látni az Asust, akkor több lehetőséged lenne, azzal gyakorlatilag bármilyen funkcióra képes lehet a router, amire a gyári szoftverrel nem biztos. De ezt is csak olyanoknak ajánlom, aki nem riad vissza a terminálos konfigolásoktól stb tehát ennek ez a hátránya, de ugyanúgy beüzemelhető rajta az OpenVPN, nem kötelező WAN portra dugni semmit és gyakorlatilag bármire képes tűzfallal rendelkezik. AP (nem natoló) eszközre tökéletes lenne. 

Más nem nagyon jut eszembe, hogyan lehetne megoldani a problémát. 

Megjegyzés megosztása


Link kommenthez

Köszönöm a infókat. Sokat segítettél.

Az ASUSnak van egy Merlin féle firmware-e.  Megnézem azt, hátha azzal lehet ilyeneket.

Szép Napot!

Sunny

Megjegyzés megosztása


Link kommenthez

Nagyon kivancsi vagyok hogy hogyan oldod meg a problemadat.

Pontosan ugyan ez a bajom nekem is.

Ha a vegen mukodesre birod a vpn szervered es ezt ossze is foglalnad hogy hogyan sikerult, akkor orokre halas lennek neked :)

Megjegyzés megosztása


Link kommenthez

Végül az volt a megoldás, hogy mindent úgy hagytam ahogy volt és btz tanácsára, kikapcsoltam a tűzfalat az ASUS-on.

Innentől fogva, engedte a bejövő forgalmat a WAN porton.

A VPN is működik :

- ASUS WAN lába az ONT LAN-ján, gateway az ONT

- ONT-n 1194-es port az ASUS WAN lábára irányitva

- ASUS-on firewall kikapcsolva

- ASUS-on VPN server beallitva

Eddig jutottam tegnap éjjel, de a sebesség max 20 Mbit-re jön ki, ami messze alulmúlja a várakozásaimat illetve mások eredményeit ezzel a routerrel (AES-NI-t tudó proci van benne tehát kéne bírnia...)

Ma reggel megnéztem, hogy LAN-on mit tud VPN-nel és ott simán 150-200 Mbit-tel csinálta a dolgát. (SFTP és CIFS volt a teszt, a VPN cm a LAN-on az ASUS WAN lába volt.)

Nem tudom hogy az ONT az akadály (routing teljesítmény), vagy hogy az ONT csinálja a port forward-ot, de a neten keresztül minden lassabb...

Ma még próbálkozom az MTU változtatásával illetve VPN bufferek állíttgatásával. Meglátjuk mi lesz belőle...

Ha semmi nem segít, akkor btz másik opicóját is kipróbálom majd, de azt probálom kikerülni, mert az az egész hálózatom átszervezésével járna...

Megjegyzés megosztása


Link kommenthez

Nagyon szépen köszönöm a részletes leírásodat.

Ki fogom én is probálni ezekkel a beállításokkal.

Én kicsit már feladtam, de most ujra bele vetem magam :)

 

Megjegyzés megosztása


Link kommenthez

Vendég
Vendégként kommentelsz. Ha van fiókod, kérünk, jelentkezz be!