Api1977

IPTV + NET routeren keresztül

Kérdés

Kedves Fórumtársak és Szakértők!

Lenne egy számomra fontos megoldandó probléma. Kicsit hosszú leszek, de próbálok mindent leírni, hogy tudjatok minél pontosabb tanácsokat adni.

Szóval adott egy 1000 Mbit-es NET+IPTV szolgáltatás.

A Telekom egy Sagemcom F@st 5655v2 AC-t adott a szolgáltatáshoz. Ezt az eszközt én csak modem (PPPoE) üzemmódban használom, mert a Sagemcom sajnos a legfrissebb firmjével is alkalmatlan a port forwarding-ra. (Ezt a Telekom szakszervize állapította meg!) Router funkcióra vettem egy TP-Link Archer  C7 AC1750-es eszközt, mellyel már tökéletesen megy aktívban a torrent feltöltés is. Viszont nekem jó lenne ha a két IPTV-s STB mellett lenne 1-1 működő al-router is melyekből el tudnám vezetékes nettel látni az ott lévő eszközeimet is (a WiFi nekem nem elegendő megoldás).

Ha a TP-Link Archer routerembe bekötöm az UTP kábeleket melyek a TV-khez mennek, és a TV-k mellett 1-1 routerrel elosztom a netet (egyébként ezek a routerek jelenleg Dinamikus IP-vel csatlakoznak az Archerre) egy ideig működik az IPTV (kis kompromisszummal, azaz lassabb a csatorna váltás és a két STB nem látja egymást egy hálózaton, de ezzel együtt tudnák élni), majd kb 18-24 óra működés után az IPTV kifagy és nem működik tovább semmilyen csatorna. Az internet továbbra is megy ezeken "al-routereken". Ilyenkor csak a reset és a tápkábel kihúzása segít... ami valljuk be nem igazán elegáns megoldás.

Hogyan tudnám én ezt a rendszert jól és használhatóan összerakni?

Csatolok néhány fotót a routerek setupjáról: (csak a fő-routerről AC7 és az egyik al-routerről teszek fel fotót, mert a másik al-eszköz szinte ugyan az.)

Megj.: A kék setup a fő-router Archer a zöld pedig az al-router. Bocsánat ha kissé szakmaiatlanul fogalmaztam itt-ott,! :) Sajnos nem vagyok IT-s.

Tisztelettel várom segítőkész válaszaitok!

Api1977

imageproxy.php?img=&key=4d4faa2b0b2835daimageproxy.php?img=&key=4d4faa2b0b2835da

 

ac1.png

ac2.png

ac3.png

ac4.png

ac5.png

wr1.png

wr2.png

wr3.png

wr4.png

Szerkesztve ekkor: Szerkesztő: Api1977

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

33 válasz erre a kérdésre

@Api1977

Akkor próbáld még meg, hogy a DNS az maradjon a fő router IP-je a GW pedig az ONT. 

Én szivesen megnézném személyesen, de Kecskemét messze van. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Leírhatnád pontosan, hogy mi az alapprobléma.
Talánt tud valaki segíteni a megoldásban jelentős átalakítások nélkül is.

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@btz

Sok mindent én sem értek... egyszerűen annyi mindent kipróbáltam már, és annyi módon összekötöttem már mindent mindennel, hogy már csak a "nagy számok törvénye" alapján is működni kellett volna valamelyik módon a rendszernek... de sehogy sem jött össze. :(

Ez számomra már olyan mértékben frusztráló, hogy lehet inkább feladom. Nem értem, hogy aminek általános rend szerint működnie kellene, miért nem működik. Pedig van egy nagyon minimális "hozzáértésem" e témához még ha ez jelen esetben nagyképűnek is hangzik.

Kipróbáltam azt is amit utoljára írtál. Fix IP az STB-k nek, ha a fő-router a gateway, akkor semmi, ha az ONT, akkor meg DNS szerverhez akar csatlakozni...

Kezd elegem lenni, talán egy szakembert kellene hívnom, aki vagy elöntené, hogy melyik eszközben van a hiba vagy rámutatna arra, hogy én hol rontottam el akármit is.

Apropó, nem tud valaki Kecskeméten szak értőt/segítőt találni? 

Köszi mindent!

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Api1977

Érdekes hogy miért nem kapnak IP-t ha a fő routered oszt ki IP címeket, elvileg át kéne menjen az ONT-n keresztül is a FŐ router DHCP szervere által adott IP, de hogy az Alrouteren mért nem megy át, azt már végkképp nem értem.

Igen pl. 192.168.1.4. és 5 jó lesz, ha azok nincsenek használatban. Próbáld meg először hogy az ONT címe legyen a getway és próbáld ki azt is hogy a főrouter IP címe.. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@btz

A fő-routeren eddig is be volt kapcsolva az IGMP az al routeren pedig IGMP bekapcsolás után sem változott semmi.

A  direktben ONT-re kötött STB továbbra is lassú és csatornaváltásoknál akad.

Az al-routernél szintén max 8 másodperc egy csatorna nézhetősége utána kifagy. De ezek is csak akkor működnek, ha az ONT-ben a DHCP be van kapcsolva. Ha a DHCP ki van kapcsolva az ONT-ben, akkor az STB-k nem is kapnak IP címet. Az STB kiírja, hogy keresi/kéri, majd nem kap és annyi... leáll a betöltése.

Azt még megpróbálom, hogy kézzel állítok be statikus IP-t az STB-knek, de majd csak holnap...

Ide miket kell majd beírnom? Én adjak neki IP-t (pl.: 192.168.1.4 és 5) A gateway mi legyen, ONT címe? DNS is kér, az mi legyen? Az alhálózati maszk, gondolom 255.255.255.0

Szerkesztve ekkor: Szerkesztő: Api1977

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Api1977

Az alrouteren a LAN-nál kapcsold be az IGMP funkciót, illetve ellenőrizd, hogy ez a fő routeren is be van e kapcsolva. 

Amikor azt írják a boxok hogy nincs internet, akkor meg kéne nézni, hogy biztosan kaptak e vagy nem IP címet, illetve ha kaptak akkor milyen IP-t és átjáró címet kaptak? Illetve azt is meg kéne nézni, hogy statikusan beállított IP-vel mennek e, de úgy hogy az ONT címe van nekik megadva átjárónak. 

Szerkesztve ekkor: Szerkesztő: btz

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@btz

Először egy rövid kitérő a tegnapihoz: Amikor a portforwarddal küzdöttem, én sem a kliens tesztelőjére hagyatkoztam, hanem erre: https://portchecker.co/ és sajnos amíg az ONT volt csak, nem is működött a port nyitás, viszont amint az új Tplink router rendszerbe áll PPPoE kapcsolattal, azonnal ki tudtam nyitni a szükséges portot...

Na most vissza a problémámhoz. Hol is kezdjem... Megcsináltam mindent úgy ahogyan írtad. Sajnos még sem működik a rendszer.

Részletezem: A tegnap rajzolt ábra szerint kötöttem be az eszközöket. Természetesen a javításodat is beleértve.

Első körben a DHCP kikapcsolva az ONT-n és az Al-routerben.

Eszköz IP címek:

ONT: 192.168.1.1

Fő-router: 192.168.1.2

Al-router: 192.168.1.3

Fejlemény: Internet van mindenhol a számítógépen, mobilon, stb. IPTV Nincs, azt írják az STB-k, hogy sikertelen csatlakozás, nincs Internet. Gondolom nem kapnak IP címeket.

Megj.: az egyik STB direktben az ONT-re van csatlakozva, a másik a ház túloldalán az Al-routerből kapna jelet.

Ha az ONT-n visszakapcsolom a DHCP-t akkor lesz IPTV-m, viszont kb 8 másodperc után kifagy minden csatorna az Al-routerből leágazó STB-n. Az ONT-be csatlakoztatott STB-n tovább mennek a csatornák, viszont minden váltáskor 3-5 másodpercig kifagy a csatorna majd lassan meg-meg állva elindul az adás az adott csatornán. Továbbá rettentő lassúvá válik az STB reagálása, ami főleg a különböző IPTV-s online dolgokban mutatkozik meg leginkább (videotéka, felvétel, stb.) Ez csak akkor szűnik meg ha az ONT-ből kihúzom a LAN-LAN csatlakozást, ami a Fő-routerrel köti össze. Innentől kezdve nem fagyogat a csatornaváltáskor és villámgyors lesz.

Próbából a Fő-routeren is kikapcsoltam a DHCP-t, a helyzet akkor is ugyan ez maradt.

Eddig jutottam. Szerinted hogyan tovább? Csatoltam képeket a routerek setup-jairól. Hátha segít.

alr1.png

alr2.png

alr3.png

for1.png

for2.png

Tkom1.png

Tkom2.png

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Rendben, akkor holnap. 

Én már távkapcsolatban állítottam be ilyet. Online port checkerrel kell ellenőrizni, hogy nyitva van e a port. Az Utorrent kliensre nem kell adni, az néha fals dolgot ír ki. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@btz

Továbbra is köszönöm a segítséget, holnap ismét nekifutok, ma már a család nem respektálja tovább ezt a tevékenységemet. ;)

@Kalimera

Az az igazság, hogy ennek a Sagemcom ONT-nek a portforwardingjával nem csak én, hanem a Telekom online segítsége sem boldogult. Egyszerűen az eszköz nem nyitotta ki akármilyen portot is állítottam be neki. A torrent kliensben ezért csak passzív voltam. Az online support is amelyik sikerdíjazással dolgozik is kb 30-40 perc után feladta a küzdelmet. Pedig távoli eléréssel iranyitotta a gépem. Majd felvett az estről egy hibajegyet, hogy rossz az eszköz. Ezután a kiszálló szervizes annyit mondott, hogy ne is küzdjek ezzel az eszközzel, mert ezeknek a szofvere rossz és nem lehet vele direktben forwardolni, csak ha PPPoE-re kapcsolom és egy jobb routerrel betárcsázva, azon állítom be a szükséges portokat. Így működik is a portforward és aktív vagyok, de ettől függetlenül jelenleg már azon ügyködnék, hogy a ház távoli helyiségeiben is tudjak vezetékes netet osztani az ottani eszközeimnek. 

Tudom, hogy bonyolult vagyok és a legtöbben nem is foglalkoznának ezzel, de én a csekély tudásom ellenére is szeretnék egy minden igényt kielégítő hálózatot kiépíteni/beállítani. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Igen az kell hogy működjön. Nem tudom hogy ki állította neki, hogy ez az ONT alkalmatlan rá, de nagy észkombájn lehetett 😃

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Api1977

Egészen biztos, hogy a torrentezés miatt ilyen átalakításokra van szükség?
Mit nem sikerült beállítani?

A F@st 5655v2 digitális elosztóhoz vezetékesen 17 pontról csatlakozom.
Torrentezek is, bár ebben nem vagyok nagy spíler.
Másik routert csak WiFi hozzáférési pontként használok a többi switch.
A ritkán üzemelő Web szerverhez is működik a port továbbítás.

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Elsőkörben

IMG_20181105_193344.jpg

Az alrouternek ne használd a WAN oldalát, DHCP szoogáltatást azon is kapcsold ki

A főrouteren DHCP legyen bekapcsolva. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Csatoltam egy rajzolt fotót a rendszerről amit összeraktam... :/ Szerinted hol a hiba?

Továbbá a következőket tapasztaltam:

Ha az ONT-ben a DHCP-t kikapcsolom, azonnal megszűnik az IPTV szolgáltatás (eszköz újraindítás sem segít). Az STB az áramtalanítás után kap IP címet (legalább is ezt írja a TV képernyőn), de az adás nem indul meg.

A net működik a Számítógépen (az al-routerre kötve), de IPTV nincs. 

Pedig az eszközök LAN címeit az ajánlásod alapján állítottam be, minden eszköznél külön-külön.

ONT: 192.168.1.1

FőRouter: 192.168.1.2

AlRouter:192.168.1.3

Az al-routernél próbáltam a bejövő UTP kábelt mind a LAN, mind pedig a WAN portba csatlakoztatni, de egyik megoldással sem működött az IPTV. Net is csak akkor volt, ha a WAN-ba csatlakoztam.

 

Nem értem... ez csak nálam nem akar összejönni, vagy lehetetlen dolgot próbálok összehozni?:S

 

IMG_20181105_185613 (1).jpg

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Rendben. Rakd össze a leírtak szerint a hálózatot. Vigyázz hogy ne legyen egyforma az ONT és a saját eszközöd LAN IP címe, de egy alhálózatot képezzenek. Ha problémád akad, akkor jelezd itt. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Köszönöm... Komolyan mondom, ezzel a "kínlódással" amit itt művelek a routereimmel meg ezzel a hálózattal, a segítségetekkel több infót és tudást gyűjtöttem be mint az eddigiekben bármikor. Köszönöm még egyszer. Holnap veszek még UTP kábelt és megcsinálom amit írtál. :)

 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Api1977

Optikán nincs modem mód, csak a Passthrough. Igen ugyanúgy oszt IP-t az ONT is, mivel teljesértékű router funkciójában működik továbbra is, csak te a főroutert használod gatewaynek. De ha lenne még egy PPPOE sessionod, akkor ugyanúgy be tudnád "tárcsázni" a WAN részét a Sagemnek is, és így ide oda váltogatva mondjuk egy wifis telóval a két eszköz wifije között kívülről úgy tűnne, mintha két különböző netkapcsolatról jönnél. De ezt csak érdekességképpen írom le. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Ahh, köszi. :)

De, ha ez modem üzemmódban van  passthrough-ban, akkor hogy kapcsoljam ki benne a DHCP-t? Ez az eszköz ugyanúgy oszt IP-t ha csak modemként dolgozik?  

Szerkesztve ekkor: Szerkesztő: Api1977

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Api1977

Igen azt 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

IMG_20181104_184743.jpg

Ide kéne még egy vezeték és kilóni a DHCP-t az ONT-ban és kb ennyi lenne az egész. Persze a főrouter és az ONT egy LAN beállítás szerint legyen. Pl ONT 192.168.1.1 saját cucc 192.168.1.2, alrouterek 3...4...5....satöbbi.

(A pirossal jelölt rész lenne a LAN-LAN kapcsolat, az általad kékkel rajzolt pedig a LAN-WAN kapcsolat) 

Szerkesztve ekkor: Szerkesztő: btz

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Huhh köszi! :) Rajzoltam már egy "Móricka" rajzot az előbbihez, de akkor holnap csinálok egy kulturáltabb ábrát is... 

Szerkesztve ekkor: Szerkesztő: Api1977

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

De a fő router és az ONT között akár lehet 2*5 centis vezeték is, nem kell kibontani a falat, oda már elég lesz az egy vezeték is. Tehát a fő router és az ONT egy helyen lenne, nem lenne köztük se fal semmi, csak két rövid vezeték. A falban onnantól elég lenne az az egy vezeték, abban már menne az IPTV és a NET is. Ha tudsz, rajzold le a Házad alaprajzát, a falban lévő vezetéket és a végpontokat, aminek net vagy IPTV kell és én megpróbálom berajzolbi rá, hogyan menne, a hálózat ha lesz időm gépelé ülni, mert jelenleg mobilról vagyok. 

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Igen, de pont ez nem jöhet nekem számításba, ugyanis 1 db UTP kábel (a falban 1 db UTP kábel van behúzva) megy a TV-hez a ház egy másik emeletén és ezen kellene a netnek és az IPTV-nek is mennie, majd az STB előtt egy 2-es számú ún. al-routeren/switch-en elosztani a jelet a számítógép és az STB között. Ez az ami nem megy, jelenleg, sajnos...

rajz.jpg

Szerkesztve ekkor: Szerkesztő: Api1977

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

@Roli82

Optikán passthrough van, de ha az ONT és a passthroughozott saját router LAN-on össze van kötve (tehát egy LAN része), akkor mindegy melyik szavad portba dugja a kanócát, legyen az az ONT vagy bármelyik saját cucx,c, mindegyiken kell működnie az IPTV-nek és a NET-nek is és ehhez semmilyen külön beállítás nem szükséges, sem a főrouteren sem az arra csatlakoztatott alroutereken, hisz onnantól épp ugyanolyan, mintha közvetlen lenne dugva az ONT-ba

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon
1 perce, btz írta:

Én összekötném egy LAN kapcsolattal is a fő routert és a ONT-t, az minden külön beállítás nélkül átvinné a LAN-on az IPTV forgalmát, és mindenfele el lehetne osztani az alroutereken is, bármelyik portján. 

Vagy a Sagemre rákötni a boxokat mert elvileg optikán modem módban is megy az IPTV.

Bejegyzés megosztása


Link a bejegyzéshez
Megosztás más oldalakon

Hozz létre egy fiókot vagy jelentkezz be a kommenteléshez

Ahhoz, hogy kommentelhess, tagnak kell lenned.

Fiók létrehozása

Hozz létre a közösségünkben egy új fiókot. Igazán egyszerű!


Új fiók regisztrálása

Bejelentkezés

Már van fiókod? Jelentkezz be itt!


Bejelentkezés most